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!

Introduction!

!

There is background radiation everywhere on Earth: from rocks, gasses, cosmic rays, nuclear
waste and many other sources. There has never before been a large-scale survey of background
radiation using a detector that can capture anywhere near the level of detail that a Timepix or
Medipix2 chip can. Radiation Around You (RAY) is a research project that aims to measure
background radiation levels and properties around the UK using the full power of the Medipix
technology.!

Aims!

!

The first aim of RAY is to construct a map or maps of background radiation across the UK
using ArcGIS software. Data taken outdoors by diﬀerent schools, of the rate, type and,
potentially, energy of radiation, will be collected together on the map, where it can be analysed.
After this task is completed trends in the data may be identified, and even correlated with any
number of factors: weather, solar activity, geology in diﬀerent areas, medical records, or indeed
anything else with which we could potentially identify a correlation. All stages of analysis could
be performed by any school within the CERN@school collaboration.
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Data Capture Procedure!

!

The following section describes, step by step, how to take data outdoors for RAY, from first
assembling the equipment to uploading the data to ArcGIS. There are currently two models of
pixel detectors used in CERN@school: the Mk-1 Timepix detector and the Jablotron MX-10
Medipix2 detector. This first section describes the process for a Mk-1 kit, followed by the
MX-10. After this a section is given to documentation.!

!
The guide below is specifically for use with RAY. A more comprehensive guide is available at:!
cernatschool.web.cern.ch

MK-1 DETECTOR KIT!

1. Gather the required equipment. This
includes:!
• Mk-1 Timepix detector.!
• A high-voltage cable.!
• The mini-USB cable.!
• A clamp, boss and retort stand for
holding the detector in place.!

Note: A lot of steps to do with detector settings may seem unnecessary to repeat at the
start of every exposure, as Pixelman remembers many of the settings from previous
runs. However, we have noticed that it
seems to do so somewhat temperamentally,
and the threshold values need periodic resetting, so running through the complete
procedure every time is necessary to increase reliability and reduce error. If you are
taking data for your own use that does not
need such full scientific rigour (such as for a
public demonstration), and Pixelman runs
without obvious error upon startup, then
you can skip these steps; however, for RAY
data, it is important that they are followed
every time.

• A smartphone with Collector for ArcGIS installed.*!
• A PC laptop computer (fully charged) with JPixelman installed.!
2. Set up the laptop. !
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3. Create a file in a basic text editor, such as Notepad. This is your documentation for the
data capture. Detail of exactly what should be documented is given later. If it seems more
convenient, then of course a physical record would suﬃce, but the information will need to
be transferred to a digital record later.!
4. Attach the high voltage cable. It is very important that this is done before the
detector is connected to the computer, as connecting the detector to a power source
before the high-voltage cable is attached could damage the detector.!
5. Set up the detector. Mount the detector in the clamp and position facing down for
standard RAY data. Face-up on a suitable surface is fine for other purposes.!
6. Connect the laptop and detector using the mini-USB cable.!
7. Open JPixelman. If you do not have it installed then it can be downloaded from http://
aladdin.utef.cvut.cz/ofat/others/Pixelman/Pixelman_download.html . This should
automatically open a window for the detector. If it does not, then right click on the
Pixelman Icon in the notification area, and click “Find new Mpx devices”: this should bring
up the window.!
8. Reset Pixels. This is done by clicking File > Reset Pixels Cfg > All Bits.!
9. Set mode as Time over Threshold.!
10. Set Bias = 95. This is the bias voltage passed across the detector chip: a higher voltage
means a greater sensitivity as smaller charges can be picked up.!
11. Ensure that “Tpx Clock” = 10.!
12. Run a Threshold Equalisation process.
This is accessed by clicking Tools >
Threshold Equalisation, and clicking
“run” in the window shown in Fig. 1.
This should take about 20-30 minutes. !
13. Note all the numbers on the
Threshold Equalisation window in
your record. Also save the distribution
as a text file, by clicking “File”,
choosing an appropriate file name and
location and clicking “save”.!

Fig. 1: Threshold Equalisation of Mk-1
chip, JPixelman software.

14. Set THL value to 40 less than that given by the Threshold Equalisation. This is the value
given both as the “mean equal”. So, for instance, if the Threshold Equalisation gives a THL
value of 412, then change it to a value of 372.!
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15. Ensure that DAC values are correct,
as shown in Fig. 2. Note that the
IKrum value is useful to change for
usage of the detector kit outside of
RAY – a lower value means a higher
sensitivity to ionising radiation but
also a higher sensitivity to noise,
especially from bright or sudden lights.
Fig. 2: DAC control panel of Mk-1 chip,
For RAY, though, the value should be
JPixelman software.
kept to 5 – this is a decent balance between
sensitivity and noise reduction for outside
environments, and it must be kept constant across all measurements by diﬀerent schools. !
16. Set “Acq. Type” as “Frames”. This means that each separate exposure will be saved as a
separate file. For non-RAY usage, “Integral” mode is useful: this stacks all exposures on top
of each other, saving them as a single file and displaying the aggregate of all frames yet
taken on screen. This is especially useful for demonstration purposes and for testing the
chip to see if it works and is set up correctly. !
17. Set “Acq. Count” as 90. This means that 90 exposures in total will be taken.!
18. Set “Acq. Time [s]” as 60. This means that each exposure is 60 seconds long. Therefore, the
standard RAY exposure includes 90 60-second frames, and takes just over 90 minutes to
run. Of course, both of these values can be freely changed outside of RAY usage.!
19. Tick “File output”. This means that JPixelman will save the exposure. !
20. Set file type as “ASCII [X,Y,C]”. This means that JPixelman will save the file as a list of
active pixels, giving the X, Y and energy values
Setting
Value
of each active pixel.!
21. Ensure that “single file” is unchecked.!
22. Set a suitable file path. The standard RAY
exposure will create 180 separate files: 2 for each
frame, one giving the ASCII [X,Y,C] location of
active pixels, and the other detailing the settings
with which that frame was taken, along with
other details. Therefore, you should create a
separate sub-directory for the data within a
directory for the experiment as a whole, which
should also include your documentation. After
you have entered the file path for the
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95 V

Tpx Clock
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THL

Threshold equalisation - 40

IKrum

5
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Figure 3: Acquisition settings for data
capture with the Mk-1 Timepix detector
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subdirectory in which you want your data to be stored, simply add a “\” followed by the
name you want for your data files. JPixelman will add a number to the end of this for each
file to diﬀerentiate between the frames.!
The naming scheme for RAY data is as follows:!
RAY_location_school_date_yourinitials-otherinitials

For example, if we were to take data on the 2nd of September at Simon Langton
Grammar School for Boys' field, we might enter the following in the text box: “C:
\Users\username\Documents\RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB\data
\RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB”. This

would create files named
“RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB01” (only with varying numbers at the end),
in the subdirectory “data” within the directory for the whole experiment named
“RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB”. Note that there cannot be a single space
in the full file path of the created files.!
23. You can now press “Start”. The frames will be saved as they are taken.!
24. When this is done, or as the data is being taken, load up the "Collector for ArcGIS" app on
your smartphone.*!
25. Log into your school's account if you have not already. You should have received your
username from an admin at The Langton Star Centre. If you have not changed your
password, then it should be "radiation2014".!
26. Select "RAY map 1.0". !
27. Select the "+" button to add a new feature to the map. Your location should be
automatically detected. Fill in as many of the details on the phone screen as you are able;
any details can be filled in or changed from a desktop computer. “Chip ID” can be found by
right clicking the Pixelman icon in the notification area - in the menu option that appears,
the string of numbers and letters (excluding the “USB” preamble) is the Chip ID.!
28. Tap the paperclip at the bottom of the phone screen to add an attachment, then click on
“camera”. Take pictures from your phone camera of as many details as seem relevant: the
sky to showcase the weather, the set-up of the chip, the general surrounding area, etc. !
29. Press the “submit” button. This will create a “feature”, or point on the map, at your
location.!
30. After you have taken all your data and finished your documentation, compress the data and
documentation into a zip folder. Name it according to the same protocol as the file name;
my zip folder would be called “RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB.zip”. We
recommend storing this in the same folder as the documentation and data.!
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31. After returning back to school or home or wherever else is convenient, log into ArcGIS at
https://www.arcgis.com/home/signin.html. Find “RAY map 1.0”: this can be done by
clicking on “groups” in the top bar, then “Radiation Around You” on the list of groups, then
“RAY map 1.0” on the list of maps. Alternatively, after logging in, you could go to: !
http://thelangtonboys.maps.arcgis.com/home/group.html?
owner=jjbeesley&title=Radiation%20Around%20You

32. Find the feature on the map that you have created, and fill in whatever details you did not
fill in on the field. The Alpha, Beta and Gamma rate can, for now, be left blank.!
33. Add your compressed zip folder containing your data and documentation as an attachment
to your feature.!
34. You have now successfully expanded the RAY map: thank you for your help!!
* Note that it is entirely possible to take and upload data without use of a smartphone. When
you log onto ArcGIS online, you can create a new feature by clicking “edit” on the top bar
(with a picture of a pencil), and then “New Feature” on the sidebar that appears. All the details
can then be filled in, and picture attachments added. If doing this, though, great care should be
taken to document the exact location at which the data was taken, so that the feature can be
accurately placed.!

M X- 1 0 D E T E C T O R K I T !
Installation of the required software for the MX-10 is more complicated than for the Mk-1. An
instruction manual detailing the installation process from the USB stick should come with the
kit, though it can also be found at www.particlecamera.com/images/dokumentary/
JABLOTRON_MX-10_BASIC_EN.pdf . The following guide assumes that the software is already
successfully installed.!
1. Gather the required equipment. This includes:!
• Mx-10 Medipix2 detector.!
• Mini-USB cable.!
• A clamp, boss and retort stand for holding
the detector in place.!
• A PC laptop computer (fully charged) with a licensed
version of Pixelman installed.!
• A smartphone with Collector for ArcGIS installed.*!
2. Set up the laptop. !
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3. Create a file in a basic text editor, such as Notepad. This is your documentation for the
data capture. Detail of exactly what should be documented is given later. If it seems more
convenient, then of course a physical record would suﬃce, but the information will need to
be transferred to a digital record later.!
4. Set up the detector. Mount the detector in the clamp and position facing down for
standard RAY data. Face-up on a suitable surface is fine for other purposes. Remove the
cover.!
5. Connect the detector to the computer using the mini-USB cable.!
6. Tick “Finite count of steps”.!
7. Make sure “Integral mode” is unchecked. This sets it so each frame is saved as a separate
file rather than all frames being aggregated into a single frame. !
8. Make sure that “delay” is 0.!
9. Set “Exp. count” to 90. This means that Pixelman will take 90 exposures in this run.!
10. Set “Exp. time” to 60. This means that each exposure will last 60 seconds. Therefore, the
standard RAY exposure includes 90 60-second frames, and takes just over 90 minutes to
run. Of course, both of these values can be freely changed outside of RAY usage.!
11. Press “Start”, and wait for the data to be taken. !

Setting

Value

Finite count of
12. Save the data. To do this, click on File > Save
Selected
steps
measurement. Choose a directory and then enter a
Deselected
filename. The standard RAY exposure will create 180 Integral mode
separate files: 2 for each frame, one giving the ASCII
Delay
0
[X,Y,C] location of active pixels, and the other
Exposure count
90
detailing the settings with which that frame was
Exposure Time
60
taken, along with other details. Therefore, it is
highly recommended you create a separate subFigure 4: Settings for data capture with
directory for the data within a directory for the
the MX-10 Medipix2 detector
experiment as a whole, which should also include
your documentation. For RAY data it is recommended that you name both your
experiment directory and files according to the date and location that it was taken. !

The naming scheme for RAY data is as follows:!
RAY_location_school_date_yourinitials-otherinitials

For example, if we were to take data on the 2nd of September at Simon Langton
Grammar School for Boys' field, my full file path would be: “C:\Users\username
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\Documents\RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB\data
\RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB”. This

would create files named
“RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB01” (only with varying numbers at the end),
in the subdirectory “data” within the directory for the whole experiment named
“RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB”. Note that there cannot be a single space
in the full file path of the created files.!
13. When this is done, or as the data is being taken, load up the "Collector for ArcGIS" app on
your smartphone.*!
14. Log into your school's account if you have not already. You should have received your
username from an admin at The Langton Star Centre. If you have not changed your
password, then it should be "radiation2014".!
15. Select "RAY map 1.0". !
16. Select the "+" button to add a new feature to the map. Your location should be
automatically detected. Fill in as many of the details on the phone screen as you are able;
any details can be filled in or changed from a desktop computer. “Chip ID” can be found by
right clicking the Pixelman icon in the notification area - in the menu option that appears,
the string of numbers and letters (excluding the “USB” preamble) is the Chip ID.!
17. Tap the paperclip at the bottom of the phone screen to add an attachment, then click on
“camera”. Take pictures from your phone camera of as many details as seem relevant: the
sky to showcase the weather, the set-up of the chip, the general surrounding area, etc. !
18. Press the “submit” button. This will create a “feature” or point on the map at your location.!
19. After you have taken all your data and finished your documentation, compress the data and
documentation into a zip folder. Name it according to the same protocol as the file name;
my zip folder would be called “RAY_SLBSfield_SLBS_08-09-14_JB-JAL-RB”. We
recommend storing this in the same folder as the documentation and data.!
20. After returning back to school or home or wherever else is convenient, log into ArcGIS at
https://www.arcgis.com/home/signin.html. Find “RAY map 1.0”: this can be done by
clicking on “groups” in the top bar, then “Radiation Around You” on the list of groups, then
“RAY map 1.0” on the list of maps. Alternatively, after logging in, you could go to: !
http://thelangtonboys.maps.arcgis.com/home/group.html?
owner=jjbeesley&title=Radiation%20Around%20You

21. Find the feature on the map that you have created, and fill in whatever details you did not
fill in on the field. The Alpha, Beta and Gamma rate can, for now, be left blank.!
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22. Add your compressed zip folder containing your data and documentation as an attachment
to your feature.!
23. You have now successfully expanded the RAY map: thank you for your help!!
*Note that it is entirely possible to take and upload data without use of a smartphone. When
you log onto ArcGIS online, you can create a new feature by clicking “edit” on the top bar
(with a picture of a pencil), and then “New Feature” on the sidebar that appears. All the details
can then be filled in, and picture attachments added. If doing this, though, great care should be
taken to document the exact location at which the data was taken, so that the feature can be
accurately placed.!

D O C U M E N TAT I O N !
Along with the data, you should also produce a text file giving details about your procedure. It
should include the following:!
• If using the Mk-1 chip, then you should include all numbers associated with the threshold
equalisation scan. Especially important is the final THL value obtained and the corrected
value used after you have subtracted 40.!
• Chip ID: This can be found by right clicking the Pixelman icon in the notification area - in
the menu option that appears, the string of numbers and letters (excluding the “USB”
preamble) is the Chip ID.!
• The date the data was taken.!
• The times the exposure began and finished.!
• The qualitative location in which the data was taken, as well as the latitude and longitude in
degrees to six decimal places. Google maps is useful for collecting this information.!
• The altitude at which the data was taken. www.freemaptools.com/elevation-finder.htm is
useful for finding this information.!
• Any ways in which the protocol deviated from the standard method detailed above.!
• Important qualitative details about the environment in which the data was taken, e.g.:!
• The weather at the time.!
• Any nearby natural or artificial features that could be important: a rock cliﬀ face, an
industrial site, a nuclear power plant, etc.!
• Whether the data was taken in an elevated position.!
• If inside, the nature of the building and proximity to windows.
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Detector Information!

!

This section describes in some detail the most important and useful settings of the chip. !

HOW

THE CHIP

WORKS!

The detector surface of Timepix and Medipix2 chips are made up of 256x256 pixels, each one
of which contains its own detector and processing layer – this is why they are known as “hybrid
pixel detectors”, because each pixel is a hybrid of detector and processing layer. The detecting
surface is made up of a silicon semiconductor P-N diode. This is composed of “P-doped”
silicon with an excess of free electron holes, and “N-doped” silicon with an excess of free
electrons, though both are neutrally charged overall due to the presence of charged ions in the
silicon. In “negative bias”, when a negative terminal is connected to the P-type silicon layer and
a positive diode is connected to the N-type silicon layer, the terminals attract free charge
carriers from their adjacent silicon layer. This creates a large depletion area where no free
charge carriers exist across the chip; charged ions are left behind as the charge carriers move
towards the terminals. This creates a potential diﬀerence across the diode. !
Large depletion area

Negative
Terminal

⊕
⊕
⊕
⊕

P-type

N-type

⊖
⊖
⊖
⊖

Positive
Terminal

Fig. 3: A P-N diode in negative bias. The P-type silicon becomes negatively charged and the N-type becomes positively
charged as free charge carriers move towards the terminals.

!

An ionising particle passing through the chip creates a large number of electron-electron hole
pairs within the depletion area. These are then attracted to either terminal, creating a current.
The current is measured at the negative terminal, which collects electron holes: this is how
ionising particles are detected. !
The energy deposited in the pixel is measured in the “Time over Threshold” (ToT) – this
means the time that the charge generated past the negative terminal exceeds a certain
threshold charge. When a particle passes through the chip, a current is generated, which acts
to build a charge in the processing electronics. An opposing constant IKrum current runs in
the opposite direction, which acts to deplete the charge. The greater the energy deposited in
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the chip by the particle, the greater the current generated and hence the longer the charge will
stay above this threshold before the IKrum reduces it below again. Therefore, the time the
charge spends above this threshold forms a measure of the energy deposited in the pixel by the
incident particle. Converting this ToT value to a real energy value in real units is a diﬃcult
process, as it involves calibrating each pixel individually.!
Both the IKrum and the Threshold have the eﬀect of eliminating electronic noise – if the
Threshold and IKrum are high enough, then the current generated by noise will never generate
a charge greater than the threshold, and so will not be registered. The problem with both of
these measures is that they decrease sensitivity – small energy deposits will not be picked up if
the IKrum and Threshold are too high. The diﬃculty is in finding the ideal balance between
noise reduction and sensitivity.!
It is important to note that the “THL” value in Pixelman works in reverse: a larger value
corresponds to a lower threshold and hence greater sensitivity coupled with greater risk of
noise.!

Charge
Threshold
Level

Time
Time over
Threshold
Fig. 4: Graph illustrating an incident particle generating a large
current, which creates a large peak in charge and hence a Time
over Threshold reading. The smaller secondary peak illustrates
noise, which is too small to make any reading and hence is ignored.

!

Charge Sharing: The diﬀerent pixels are connected to each other. When an ionising particle
deposits a large amount of energy in the chip, it creates a correspondingly large number of
electron holes that proceed towards the negative terminal. These, all being positively charged,
repel each other, and hence the charge spreads out as it moves towards the negative terminal.
This often means it spreads over multiple pixels – this is how alpha and gamma particle tracks
cover such a larger area than the area within which the particle will have deposited its energy.!
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Threshold Equalisation: Every pixel is diﬀerent, and therefore has a diﬀerent level of noise,
and therefore needs a diﬀerent threshold level. The threshold equalisation scans most of the
pixels in the detector, calculates a mean value and memorises an adjustment from this mean for
each individual pixel. Changing the “THL” value changes this mean, while the adjustment from
this mean remains as calculated from the scan.!

TECHNICAL SETTINGS!

!

Here is a short list of the most useful settings that have to do with the workings of the chip. !
Time over Threshold or Spectrometer: Under “File > Set Mode > Time over Threshold”
on the Mk-1 or “File > Measurement mode > Spectrometer” on the MX-10. This means that
the chip measures the total energy deposited in each pixel over the length of the single frame
exposure, according to the technique described above. Another useful mode could be
“Timepix”, which measures the time at which energy is deposited in pixels, but includes no
measure of the amount of energy. !
Bias, Bias Voltage or BIAS: Displayed on the main control window if using Mk-1, or under
Options > BIAS if using MX-10. This is the potential diﬀerence, or voltage, passed across the
semiconductor surface of the chip in order to create the depletion area and collect electron
holes. A greater bias voltage means a greater current generated and hence a greater sensitivity.!
Threshold Level or THL: The Threshold level of the chip. A greater THL means a lower
threshold, and hence greater sensitivity but increased risk of noise. If you are having issues
with noise, lowering the THL is often a useful solution.!
IKrum: The constant reverse current. A higher IKrum value means a lower sensitivity but
reduced noise. IKrum is especially useful for reducing noise from bright lights; at suﬃcient
intensity, UV, visible and infra-red light all generate readings on the chip. The issue of whether
physical shielding or increased IKrum is more eﬀective at blocking sunlight while retaining
maximum sensitivity, and hence the ideal procedure to follow when trying to take RAY
readings in bright sunlight, is one of much contention.!

S C R E E N D I S P L AY

!

AND

AESTHETICS!

If you want to keep track of the data as it is taken, you may want to alter how it appears on
screen. For both the Mk-1 and MX-10, you want to make sure that “Auto range” is unchecked,
put “Min Level” to 0 and “Max Level” to around 100-150. This calibrates the on-screen colour
display, setting at what arbitrary energy values the screen displays its colours corresponding to
minimum and maximum energy values. Setting the Min and Max Level at these levels generally
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allows for the clear display of ionising background radiation with energy deposits across the
whole colour spectrum. The only other consideration is the “Colour map”, which is a matter of
personal aesthetic taste. Though, of course, “Hot” is objectively the best option.!
To zoom in on an area of the display screen, drag and drop a box around a certain area, and this
area will be magnified to fill the display. Double clicking the screen will zoom out the display
to its original position. Hovering the cursor over a pixel will display its co-ordinate location
and the energy deposited in it.!
To be clear, neither the Min and Max Levels, nor the Colour Map has any eﬀect on the saved
data, only on the visual display.!

U S E F U L N O T I F I C AT I O N A R E A I C O N F E AT U R E S !

!

While running, Pixelman has an icon in the Notification Area or System Tray (to the bottom
right of the screen, usually). Right Clicking this icon brings up a menu that contains a number
of useful features, listed below.!
Frame Browser: This feature allows you to display data that you have taken and saved on
screen in the same manner as Pixelman does while it takes data live. Found through Utilities >
Frame Browser.!
Complicated Controls for MX-10: Although the MX-10 detector is considerably easier to
set up and use than the Mk-1, and has a number of new and useful features, the Mk-1 controls
do give more freedom and control over the detector. If you wish to, for whatever reason, retain
this control while running Pixelman with the MX-10 detector, click on the name of your chip
(the option that appears like a string of 0s and capital letters) > Old Medipix control. In this
window it is harder to take simple data samples, but easier to alter a number of useful settings.!
Find New Mpx Devices: Click this if Pixelman is running while a detector is plugged in, but
no control window is open. It should open a window.!

!
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Data Analysis!
The data analysis procedure takes in the raw data files and outputs the alpha, beta and gamma
particle rates. This is an optional stage for users who are comfortable with data capture, and
want to push themselves further, or users who have some prior experience of the command
line.!

C O N F I G U R I N G V I RT UA L B OX !
1. Download the RAY Analysis virtual machine from starserver.thelangton.org.uk/rayanalysis.ova!
2. Download and install VirtualBox from http://virtualbox.org!
3. Import the virtual machine into VirtualBox (File > Import Appliance; check the box labelled “Reinitialise the MAC addresses of all network cards") and start it up (select the VM
and click "Start"). Your machine will need at least 3 GB of RAM to run the VM smoothly.!

CONFIGURING

THE

VM!

1. Click the "Terminal" icon on the desktop to open a shell. The default shell is bash, which
is required to run root smoothly; type info bash (and hit enter) to learn more. An alternative shell is fish, which is more user friendly, but has some problems running root, and so
is not for use with RAY; type fish to learn more!
2. You will need to change the password for the ray user and for the superuser. The default
password is alpine, and can be changed with the passwd command. Select u, the local account, when prompted.!

MANAGING

FILES

!

If you are completely new to the command line, the following article
may be a useful primer for you: http://tinyurl.com/RAY-cmdline
1. You will need data files for your analysis. The VM contains example data in the data/testdata
folder, or you can download data from ArcGIS. For now, extract any compressed files (e.g.
from ArcGIS) with the GUI.!
2. Use cd1 to open the folder data on the desktop. Use ls2 to determine the path.!

cd changes the directory to the specified path. Unix systems use the tilde, ~, as a shortcut for
the "home" directory (in this case, /home/ray)
1

2

ls lists the files and folders in the current directory
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3. mkdir3 creates new directories, or folders. Each set of data you analyse should be contained in a new sub-folder of ~/Desktop/data.!
4. Your data from ArcGIS should have been extracted to ~/Downloads. Use ls and mv4 to
move your files to your new folder in ~/Desktop/data. TIP: the asterisk, *, acts as a wildcard,
so would match all the files in a directory.!
mv ~/Downloads/!downloaded_data!/* ~/Desktop/data/!session_folder!

SETTING

A N A LY S I S VA R I A B L E S

!

1. Open the folder containing your data and use pwd5 to discover its path in the system.
Copy this path to the clipboard (keyboard navigation doesn’t work in the shell).!
2. export creates and defines variables. Rather than repeatedly typing paths to files, we can
store the information in a variable for later use. Variables can be defined as plaintext (export var=hello) or as the output of a function (export var=`pwd` - export evaluates the
function inside the backticks before defining var).!
3. Set FILEPATH as the current working directory using export and pwd!
4. Change the current directory to the Desktop!
5. List the files on the desktop and use cat6 to read any files of interest, such as start.sh!
6. In bash, you can run scripts within the current shell, and return their output to the shell.
Type .7 start.sh to begin processing the data. Right click and paste the path you copied
earlier, and press enter. A file ID should appear, containing the date when the data was captured.!
7. Change the directory to ~/software/data-conversion-toolkit/toolkit-build. List the files, and run
Px2Mf-converter in a subshell:!
./Px2Mf-converter $FILEPATH $RUNID $FILEPATH!

3

mkdir creates a new folder within the current directory

4

mv moves the given files or folders to the given output

5

pwd prints the working directory of the current shell

6

cat is short for concatenate: it reads an input file and prints its contents to the screen

7

"dot space" runs the file in the current shell; "dot slash" runs the script in a sub-shell
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8. Go back to your data folder. List the folder contents, then pipe8 the output into grep9 and
search for files with the extension .root: ls | grep .root!
9. To store this file as a variable, you need to store both the name (generated above) and the
path. To do this, recall the FILEPATH variable ($FILEPATH) and follow it with the name of
the file: export DATAFILE=$FILEPATH/`ls | grep .root`.!

V I E W I N G , F I LT E R I N G

AND

A N A LY S I N G F R A M E S !

1. We can use the shell to run python scripts as well, with the command python. Open the
data-conversion-toolkit directory, and find the file called frame-viewer.py. Run python ~/software/data-conversion-toolkit/toolkit-python/frame-viewer.py $DATAFILE10 to
open the viewer.
2. You can create a pixel mask, so that any stuck or noisy pixels don’t aﬀect your analysis.
Open and list the toolkit-python directory, and try to run make-mask.py. The exact command
is as follows:!
python make-mask.py $DATAFILE filter.txt $FILEPATH filter n11!

3. You can apply the filter from the directory toolkit-build. Type ./Mf-filter $DATAFILE
$FILEPATH/filter.txt filter, then use the frame-viewer again to see the diﬀerence.!
4. You are now ready to analyse the data! Run rate-plotter.py with $DATAFILE and $FILEPATH as
arguments12 then look for html files in the data directory. firefox can open these files when
it is run from the same directory as them.

8

pipe is not so much a command as a feature of the shell. If you separate two commands with
a pipe, |, the output of the first is set as the input of the second
grep is a more powerful Find and Replace. grep !search_string! selects only lines
containing that search string
9

python runs the defined script, frame-viewer.py, with the argument $DATAFILE (the location of the root file)
10

n is the minimum number of consecutive hits for the pixel to be masked" - the default is
three (3)
11

12

Variables passed to a python script when it is run
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Get in touch!

!

We’re really excited about the opportunities this project enables, and grateful to you for
helping to make it a reality. If you have any questions or suggestions, please get in contact with
us through one of the methods below. We’d also love to hear about anything you’re doing with
the chips. The best way to tell us about the science you’re doing is through our wiki;
instructions to get started there are as follows:!

C R E AT I N G

!

AN ACCOUNT ON THE WIKI

!

1. Go to ray-project.org.uk or rayproject.wikidot.com (the former may be blocked by
your school - feel free to ask them to unblock it!).!
2. Sign up for an account with Wikidot (the service that hosts our website). Please use a nonidentifying username (no full names, please), and add as much or as little information as you
want.!
3. Go back to the homepage and sign up for the wiki using the secret “ray2014”, for
immediate access, or apply to join and an admin will approve you as soon as possible.!
4. Have a look around, and get started creating pages! Documentation for formatting is
available on the website, or just copy an already existing page and experiment!!

!
!

CONTACT:!
bparker@thelangton.kent.sch.uk
thelangtonstarcentre.org
cern-at-school.org
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WA N T A DIGITAL COP Y OF TH IS
GUI DE?!

!
http://starserver.thelangton.org.uk/RAY-guide.pdf
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